Прочие возможности

Открытие файлов

В программе есть возможность открытия файлов .myc, .rdp и .remmina. Для этого в пункте меню «Файл» выберите «Открыть», либо дважды щелкните на нем в файловом менеджере. После выбора необходимого файла будет произведена попытка соединения - если файл не содержит параметров или содержит ошибки, то отобразится соответствующее сообщение. В другом случае - произойдет успешное подключение к серверу.

Импорт файлов

Вы также можете импортировать параметры из файлов (.myc, .ctor, .rdp и .remmina) либо для изменения параметров, либо для сохранения в свой список подключений. Для этого в пункте меню «Файл» выберите «Импорт…», после этого откроется диалог открытия файла, а после его выбора откроется окно дополнительных параметров того типа подключения, который записан в данный файл.

Импорт из старого формата файлов .ctor помимо главного меню доступен через утилиту ctor2myc, входящую в состав пакета:

$ ctor2myc
usage: ctor2myc [-v] input.ctor [output.myc]

Также при первом запуске MyConnector и при наличие рабочей папки .connector в домашней папке пользователя будет выдан запрос на автоматический импорт всех имеющихся там соединений.

Ведение логов

Располагаются в рабочей папке программы: ~/.myconnector/logs. Файл all.log содержит отладочную информацию от запускаемых программ, а myconnector.log - информацию по работе самого MyConnector (три уровня сообщений: info, warning и error) и ошибки в его работе. В «Параметрах программы» есть возможность отключения ведения логов.

Текстовый редактор для подключений

В «Параметрах программы» можно указать редактор, используемый при нажатии кнопки «Открыть как текст» в контекстном меню списка подключений.

Справка по программе MyConnector

Ссылка на данную страницу Wiki всегда доступна из приложения - пункт главного меню «Справка». Там же краткие сведения о программе и об ее разработчике. Также справочную информацию можно просмотреть и на компьютере (данную вики планируется разместить в отдельном пакете myconnector-docs):

$ man myconnector
$ myconnector --help